Skip to end of metadata
Go to start of metadata

Achtung!

Diese Anleitung gilt für den LoxBerry der 0.2.x Serie. Die aktuellste Version ist Loxberry 1.0!

 

1. Vorbereitung

Um einen LoxBerry aufzusetzen benötigst Du folgende Dinge:

  1. Einen RaspBerry Pi Version 1, 2 oder 3
    1. Du brauchst das Grundgerät, den Raspberry
    2. Dazu ein passendes Gehäuse
    3. und ein passendes 5V-Netzteil
    4. Für WLAN brauchst du bei Raspberry 1 und 2 einen USB-WLAN-Stick (Raspberry 3 hat WLAN eingebaut), oder du schließt die Geräte direkt mit LAN-Kabel ans Netzwerk an
    5. Es gibt dafür auch fertige Bundles zu kaufen, einfach mal nach Raspberry Set oder Raspberry Bundle googeln. Achte darauf, was beim Set dabei ist (Sprich: Ist der Raspberry selbst inkludiert; ist eine SD-Karte dabei; ist  auch wirklich ein Euro-Netzteil statt eines UK-Netzteils dabei)
  2. Eine (Mini-)SD-Karte mit mindestens 4 GB, empfohlen: 8 GB
  3. Einen Kartenleser am PC, um die Karte zu beschreiben

Hier findest du eine Einkaufsempfehlung, wenn du noch keinen Raspberry hast: Hardware

2. Download

Lade Dir das aktuelle Loxberry-Image herunter. Das Image beinhaltet das komplette Betriebssystem des Loxberry und wird nach dem Download auf eine SD-Karte geschrieben.

Links zu Downloadservern mit allen Loxberry-Images findest Du unter folgendem Link: Download und Spiegel-Sites 

Achtung!

Für den LoxBerry der 0.2.x Serie gibt es noch ein letztes Update, welches im Image noch nicht integriert ist! Das Image enthält Version 0.2.3, der letzte Versionsstand ist 0.2.4. Das Upgrade auf 0.2.4 muss über den Menüpunkt "Upgrade" manuell eingespielt werden. Die Upgrade-Datei findest Du ebenfalls auf den Downloadservern unter stable/upgrades.

 

3. Image auf SD-Karte schreiben

Die heruntergeladene Image-Datei muss nun 1:1 auf eine Speicherkarte geschrieben werden. Du brauchst dazu eine leere (oder nicht mehr benötigte) Speicherkarte mit mindestens 4 GB Größe. Zum Schreiben des Images brauchen wir nun noch eine geeignete Software. Wir empfehlen Dir unter Windows die Software Win32DiskImager. Win32DiskImager kannst Du hier herunterladen: https://sourceforge.net/projects/win32diskimager/

Starte Win32Imager mit Administratorrechten (Rechte Maustaste → Als Administrator ausführen) und wähle das heruntergeladene Image aus. Achte unbedingt darauf unter "Device" den korrekten Laufwerksbuchstaben der Speicherkarte auszuwählen! Du kannst bei einer falschen Auswahl ansonsten Deine Festplatten unwiderrufbar aus Versehen löschen! Anschließend schreibst Du das Image mit "Write" auf die Speicherkarte.

 

 

Die fertig beschriebene Speicherkarte kann nun in den Raspberry Pi eingelegt werden und der RaspPi gebootet werden. Bitte schließe für die Ersteinrichtung den Raspberry Pi über ein LAN-Kabel an den Router an. Du kannst während der Ersteinrichtung dann eine WLAN-Verbindung einrichten.

Auf dem Mac ist der Weg etwas anders.

Zunächst die Karte Formatieren. Dazu kann z.B. das Tool SD Card Formatter von https://www.sdcard.org (dort unter Downloads zu finden) verwendet werden. Im Tool merken als welche Disk die SD-Karte gemounted wurde. 

In meinem Fall ist es:   disk3
Merke dir diese Nummer “3″

Nun muss die SD Karte ungemountet, aber nicht ausgeworfen werden!
Terminalclient:

sudo diskutil unmount /dev/disk3s1

Danach kann die SD Card mit dem runtergeladenen Image geladen werden:

sudo dd if=Downloads/loxberry-image-rasppi-0.2.2-frodo.img of=/dev/disk3 bs=1m

Nach ca. 10-15 Minuten sollte eine ähnliche Meldung wie diese erscheinen:

1900+0 records in
1900+0 records out
1992294400 bytes transferred in 962.101778 secs (2070773 bytes/sec)

Die SD Card nun auswerfen und im Raspberry Pi einstecken.
Raspberry Pi anschliessen und starten. Viel Spass!!

4. Erster Zugriff

 

Achtung! Wenn der Router in Deinem Netzwerk die IP-Adressen nicht dynamisch per DHCP verteilt (sehr unwahrscheinlich) und Du somit die IP-Adressen aller Deiner Netzwerkteilnehmer manuell vergibst, dann ließ bitte im Abschnitt 5 weiter, bevor Du die Ersteinrichtung des LoxBerrys beginnst. Wenn Du nicht verstanden hast worüber wir reden, dann mache einfach weiter. Vermutlich musst Du nichts weiter beachten und Deine IP-Adressen werden per DHCP im Netzwerk vergeben.

 

Der LoxBerry wird über den Browser eingerichtet. Nach dem Booten musst Du wissen, unter welcher Adresse Dein LoxBerry in Deinem Netzwerk erreichbar ist. Viele Router (unter anderem die bekannten Fritzboxen) unterstützen mittlerweile auch die lokale Namensauflösung. Versuche also als erstes Deinen LoxBerry im Browser unter seinem Namen zu erreichen:

http://loxberry

Der Username und das Passwort beim ersten Zugriff ist: loxberry / loxberry

Sollte der Zugriff nicht funktionieren musst Du die IP-Adresse Deines LoxBerrys herausfinden und diese in die Adresszeile des Browsers eingeben. Im Prinzip gibt es 2 Möglichkeiten die Adresse herauszufinden:

 

a) Über die Windows-Netzwerkumgebung

Öffne dazu ein Explorer-Fenster und gehe auf "Dieser PC". Im Abschnitt "Netzwerkadressen" sollte ein Eintrag "Loxberry" angezeigt werden. Manchmal erscheint er hier nicht, dann musst Du auf "Netzwerk" gehen und unter der Rubrik "Multimedia" nachschauen. Rufe über die rechte Maustaste die Eigenschaften auf - hier findest Du die IP-Adresse Deines LoxBerrys und auch gleich einen anklickbaren Link zur Konfigurationsseite:

 

 

b) Über Deinen Router

Dein Router sollte ebenfalls protokollieren bzw. eine Übersicht bereitstellen, welchen Netzwerkgeräten er welche IP-Adresse zugewiesen hat. Bei den bekannten Fritzboxen findest Du diese Übersicht unter Heimnetz → Heimnetzübersicht → Details.

5. Optional: Manuelle Netzwerkeinrichtung vor der Ersteinrichtung

Standardmäßig erwartet der LoxBerry einen laufenden DHCP-Server im Netzwerk, von dem er eine freie IP-Adresse zugewiesen bekommt. Wenn Du keinen DHCP-Server im eigenen Netzwerk betreibst und Du somit schon vor der Ersteinrichtung eine manuelle IP-Adresse vergeben musst, so gibt es hierzu ebenfalls eine Möglichkeit. 

Lege dazu die mit dem Image beschriebene SD-Karte in den Kartenleser Deines Rechners ein und öffne sie mit dem Explorer. Lege auf der Partition "boot" der SD-Karte eine Datei mit dem Namen network.txt an und öffne diese Datei mit einem beliebigen Texteditor. In die Datei kopierst Du folgenden Inhalt:

Feste IP-Adresse

network.txt
auto lo
iface lo inet loopback

allow-hotplug eth0
iface eth0 inet static
  address IPADRESSE
  netmask NETMASK
  gateway GATEWAY
  dns-domain loxberry.local
  dns-nameservers GATEWAY

WLAN DHCP  WLAN-NAME und WLAN-PASSWORD müssen gegen eure eigenen ersetzt werden!!

network.txt
auto lo
iface lo inet loopback

allow-hotplug wlan0
 iface wlan0 inet dhcp
 wpa-ssid WLAN-NAME
 wpa-psk WLAN-PASSWORD


 

Die großgschriebenen Angaben musst Du durch die Daten aus Deiner Netzwerkumgebung ersetzen. Nach dem nächsten Reboot übernimmt der LoxBerry diese Daten und ist im Netzwerk über die manuell angegebene IP-Adresse erreichbar, Weitere Details zur Konfiguration dieser Datei findest Du hier: https://wiki.debian.org/NetworkConfiguration#Configuring_the_interface_manually

6. Router einrichten

Es ist äußerst wichtig, dass sowohl der Loxone Miniserver als auch der LoxBerry später trotz der dynamischen Vergabe von IP-Adressen immer unter der gleichen Adresse im Netzwerk erreichbar sind. Anderenfalls kann es zu Problemen in der Kommunikation zwischen beiden Geräten kommen.

Die meisten Router bieten dazu eine entsprechende Option an, bestimmten Geräten immer die gleiche IP-Adresse per DHCP zuzuweisen. Bei den bekannten Fritzboxen findet man die Einstellung unter Heimnetz → Heimnetzübersicht und anschließend "Details". Hier hakt man die Option "Diesem Netzwerkgerät immer die gleiche IPv4-Adresse zuweisen" an.

 

 

Geschafft! Die Installation ist damit abgeschlossen und Du kannst mit der Erstkonfiguration Deines LoxBerrys beginnen!

 

  • No labels

20 Comments

  1. Hallo zusammen, die Installation verlief relativ reibungslos, bis auf eine kleines, aber wichtiges Problem.

    Loxberry glaubt, dass mein Miniserver unter der angegebenen IP nicht auffindbar ist. Über den Scan Button wird dieser jedoch gefunden.

    Der Standard Port 80 wurde nicht geändert.

    Benutzername und Kennwort mehrfach überprüft.

    Hat jemand noch einen Tipp, was ich versuchen kann?

     

    Viele Grüße

  2. Bitte Fragen im Forum stellen!

  3. Hi Michael,

    da ich spontan keine bessere Möglichkeit zur Kontaktaufnahme mit dir finde, versuche ich es mal auf diesem Weg. Finde Loxberry klasse und hab gerade einen ersten Beitrag dazu verfasst: http://www.meintechblog.de/2017/07/loxberry-in-10-minuten-auf-dem-raspberry-pi-installieren-die-ultimative-erweiterung-fuer-dein-smart-home-von-loxone/ Falls du Lust hast, würde ich mich gerne etwas mit dir austauschen - z.B. in Form eines kleinen Interviews. Würde gerne helfen das Projekt etwas bekannter zu machen.

    Grüße
    Jörg

  4. Hallo,

    danke für die Entwicklung und zur Verfügung stellen dieser tollen Software!

    Falls es jemanden interessiert:
    Man kann ohne Probleme den Loxberry auf einem QNAP-Nas als VM laufen lassen, in meinem Fall ein QNAP 253.
    Zur Installation bitte das OVA Image verwenden, das kann man dann einfach in die VM des QNAP importieren.

    Gruß
    Timur

    1. Hallo Timur, habe einen QNAP TS251 und würde auch gerne darauf den Loxberry laufen lassen aber bekomme es irgendwie nicht hin. Bin nicht so der Computer Profi.
      Könntest du mir vielleicht schritt für schritt beschreiben wie ich vorgehen muss?
      Wäre dir echt dankbar.
      Gruß Fuzzy

  5. Hallo,

    ich habe einen Raspberry Zero W und möchte darauf das Loxberry installieren. Habe dies jetzt rund 20 mal aufgespiel mit Win 32 Disc Imager. Ansonsten auch alles aus der Anleitung beachtet. Aber leider bootet der Raspberry nicht. Zum Test habe ich auch das aktuelle Raspbian ausprobiert, damit startet der Raspberry ohne Probleme. Auch mit Etcher habe ich das Image schon eingespielt. Im Netzt findet man auch noch andere Anleitungen, sind aber grundsätzlich alle sehr ähnlich. Bisher hat mir nicht zum Erfolg geholfen. Das Lämpchen beim booten hat bisher nur bei Raspbian geläuchtet. Bei Loxberry tut sich nichts. Ach ja - Formatiert habe ich die SD Karte auch schon mehrmals mit SD Card Formatter. Angechlossen ist er über ein Netzteil, habe aber auch schon USB kabel probiert - ändert nichts.

    Verwendet habe ich loxberry-image-rasppi-0.2.2-frodo.img.zip, aber auch die 0.2.1 ebenfalls erfolglos ausprobiert.

    Aktuell komme ich nicht mehr weiter. Hat jemand eine Idee woran das liegt?

    1. Habe gerade das selbe Problem...

      1. Versuch es im Loxforum. Hier erreichst du bei weitermin nicht so viele Helfer wie dort (smile)

  6. Bei mir wars anscheinend das Netzteil, getauscht und dann gings...

  7. Ist es auch möglich, Loxberry auf einem laufenden RasPi, auf dem z.B. FHEM als Middleware zu Loxone läuft, nach zu installieren oder muss ich immer mit einem Loxberry-Image beginnen?

  8. Jörn Cohrs

    Kann man sicher, hier im Wiki steht ja wie du es nachinstallieren kannst.
    Nur glaube ich das sich Einstellungen im Loxberry ggf. mit anderen Installationen überschneiden/beeinfussen können.
    Da es ein FHEM Plugin gibt würde ich dir immer raten das ganze mit einem sauberen Loxberry neu zu machen.

  9. Was mache ich nur in meinem Netzwerk falsch??? Nach langem hatte ich mich mal wieder dem Loxberry widmen wollen, bisher wenig Freude und viel Frust. Heute früh komplett die SD-Karte neu mit Image 2.2 bespielt und siehe da, der Loxberry war erstmals (nach 6 Installationsversuchen in der Vergangenheit) auf Anhieb im Netzwerk über DHCP (Fritzbox 7490) ersichtlich. Sogar im Explorer wurde er unter den Netzwerkgeräten angezeigt. Hätte ich mal nicht das 2.3 Upgrade installiert, nach dem Update ging mal wieder nichts... Wenn ich mich direkt unter Linux einlogge sehe ich, dass der Loxberry irgendwelche kruden IP-Adressen hat z.B. 169.254.82.183, was nichts mehr mit meinem DHCP-Netzwerkbereich der Fritzbox zu tun hat.

    Also alles noch mal von vorn und das zum 4. Mal heute, leider ohne Erfolg. Die Fritzbox zwischenzeitlich auf das neueste Update 6.90 aktualisiert, mit dem Ergebnis, dass er mir in der Netzwerkübersicht eigentlich genau eine gewünschte IP-Adresse anzeigt 192.168.0.xx nur leider kann ich diese Adresse weder anpingen noch erreichen?! Wie oben beschrieben, habe ich auch eine network.txt aufgesetzt und ins boot-Hauptverzeichnis kopiert, ohne Erfolg.

    Hat irgendjemand eine Idee bzw. hat mit den selben Themen zu kämpfen? Wie könnte ich direkt mit shell-Befehlen die IP-Adresse ändern und da ich noch keine Ersteinrichtung vorgenommen habe, wie lautet das root-Passwort und ist es normal, dass ich stets die US-Version der Tastatur habe?

    Vielen Dank vorab und beste Grüße Matthias

    1. Bitte nicht hier Fragen stellen, sondern im LoxBerry Forum (https://www.loxforum.com/forum/projektforen/loxberry/allgemeines-aa). Das hast du für deine Frage schon gemacht, bitte auch an alle: Hier keine Fragen, nutzt bitte das Forum. Danke!

  10. DieLoxberry- Downloadseite ist nich erreichbar. Können Sie dies beheben?

    Danke

  11. Hallo "Downloadserver down!"

    Bin neu hier und bräuchte zum anfangen die Loxberry Software (neuerste Version).

    Hat die jemand zufällig und kann sie mir zusenden? Wäre echt klasse. Möchte bei meinem Haus jetzt Sonos ins Loxone integrieren. Hoff ich bekomm es hin (wink)

    Danke und Lg Markus

     

    1. Wer lesen kann, ist klar im Vorteil!

      1. was soll das jetzt?

         

        1. Deswegen - steht ja direkt bei "Download"

          1. das war mir schon klar!! LESEN kann ich ja. Hab mir nur gedacht vielleicht hat jemand zufällig die Datei noch. 

            Wie gesagt bin hier neu und lese mich gerade überall durch und war mir nicht sicher. → Entschuldige BITTE

            1. Dort liegen ja die Dateien? Jedenfalls viel Erfolg! Fragen bitte generell im LoxBerry-Bereich des loxforum.com. Wir werden hier alle Kommentare löschen. lg, Christian