Skip to end of metadata
Go to start of metadata

Ursprung: http://adl517.at/index.php/seitenmenue/25-zaehler-lesekopf

Platine für den Lesekopf:

https://wiki.volkszaehler.org/hardware/controllers/ir-schreib-lesekopf-ttl-ausgang

Ringmagnet: https://www.amazon.de/gp/product/B00CL0IB08/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1

oder

Rundmagnet 8x3mm: https://www.amazon.de/gp/product/B01M03KWJD/ref=ppx_yo_dt_b_asin_title_o04_s00?ie=UTF8&psc=1




Wemos D1 Mini:

https://wiki.wemos.cc/products:d1:d1_mini


Gehäuse:

Deckel: http://adl517.at/images/lesekopf/deckel_amis.stl

Gehäuse klein: http://adl517.at/images/lesekopf/gehaeuse_amis.stl

Gehäuse groß z.B. für ein Powershield: http://adl517.at/images/lesekopf/gehause_lesekopf_gross.stl

Gehäuse für den Lesekopf ohne Wemos D1 mini: https://www.thingiverse.com/thing:3378332/zip

Gehäuse klein von mir bearbeitet:

gehäuse_amis_klein.stl



Einbau:

LED lose einsetzen wie hier im Bild und ins Gehäuse Einsetzen damit die LED bündig sind und erst dann einlöten




Angeschlossen hab ich den Lesekopf wie am Bestückungsplan auf Volkzähler mit 3,3V.

https://wiki.volkszaehler.org/hardware/controllers/ir-schreib-lesekopf-ttl-ausgang


Damit ich den USB Anschluss besser in Position bringen kann hab ich zur besseren Stabilität KNX Adern verwendet.

Für das Einpassen ins Gehäuse die Lesekopfplatine links und rechts etwas abschleifen damit es leichter ins Gehäuse passt.


Ausschnitt für den USB Anschluss per Dremel freimachen.

Links unten würde sich der Reset Taster am mittleren Gehäuse befinden. (eventuell etwas einschneiden für die leichtere Bedienung falls er gewünscht ist)




Ein paar Bilder:




File für den Wemos D1 Mini:

http://adl517.at/images/lesekopf/amis_ap_v17.ino.d1_mini.bin

Tasmota Flasher: https://github.com/tasmota/tasmota-pyflasher/releases


Alternativ für andere Zähler:

https://forum.creationx.de/forum/index.php?thread/1095-d0-z%C3%A4hler-sml-auslesen-mit-tasmota/&pageNo=1

https://docs.google.com/document/d/1olSGZcaE_vkdNXzN_p0zGee61xKCcK3HJe3Al00xj2g/edit?usp=sharing




Nach dem aufspielen den Wemos neu starten

Der Wemos spannt einen AP auf bei dem man sich mit SSID: lesekopf Passwort: lesekopf anmelden kann

Daten ergänzen:

Für den AES Code im Netzportal anmelden und AES Schlüssel anfordern im Portal

https://netz-online.netzgmbh.at/eServiceWeb/registration/createUser.html


Wenn alles geklappt hat dann zeigt er im Portal unter Info folgende Daten:



Eingänge per UDP:



Das Ganze klappt im Sekundentakt per UDP:


VIU_Amis-Wemos-D1-Lesekopf.xml


Json Ausgabe:


MQTT:

Zusätzlich hat er die gemittelte Leistung der letzen 1/4h, aufgetrennt auf Bezug und Lieferung (berechnet durch Zählerstände, bei Neustart ist die erste 1/4h Fehlerhaft)



  • No labels

3 Comments

  1. Hallo!

    Ich habe nach der Anleitung einen IR Lesekopf an einen Wemos D1 mini gelötet und die Firmware aus dem Link geflasht.

    Leider wird im Interface nichts angezeigt, und wenn ich mit der Handykamera schaue, ob IR - Signale gesendet/empfangen werden, leuchtet oder blinkt keine der zwei Dioden... Ist das normal?

    Ich habe den Schlüssel von Netz Oberösterreich eingegeben, auch am Stromzähler selbst sehe ich aber mit der Handykamera die Dioden nicht blinken...

    Was könnte da das Problem sein?


    Den Lesekopf hab ich von hier: https://www.photovoltaikforum.com/thread/141332-neue-lesekopf-baus%C3%A4tze-ohne-smd-l%C3%B6ten

  2. Lesekopf mal um 180Grad drehen

    LED sollten so nah wie möglich am Zähler sein

    LED ev. falsch eingelötet (Sende und Empfangseinheit bzw. auch die Polarität)

    TTL Lesekopf hab ich so angeschlossen: https://wiki.volkszaehler.org/hardware/controllers/ir-schreib-lesekopf-ttl-ausgang

    AES Code per kopieren/einfügen 


  3. Danke für die schnelle Antwort. Lesekopf drehen hab ich versucht, LED´s sind richtig eingelötet.

    Ich hab den RX - Pin an den RX Pol des Wemos und den TX Pin an den TX Pin des Wemos gelötet.

    Den AES Code habe ich heute vormittag im NetzOÖ beantragt und dann im Wemos eingetragen.

    Wenn ich die Handykamera auf das Interface vom Stromzähler halte, sollten dann IR - Signale zu sehen sein?

    Kann es vielleicht etwas dauern, bis das Interface freigeschaltet wird?( (hab den Code ja erst heute bekommen)


    Edit: Danke - jetzt funktioniert es ... Ich weiß nicht woran es gelegen ist, habe den Lesekopf noch einmal aus dem Gehäuse genommen, Lötstellen überprüft und jetzt läuft es (smile)