Zum Ende der Metadaten springen
Zum Anfang der Metadaten

Symptom

  • Deine LoxBerry Version ist unter 1.2.4
  • Beim Ausführen der Installation in "LoxBerry Update" bleibt nach Drücken des Installieren-Knopfs die Meldung "Bitte warten..." stehen
  • Im "LoxBerry Update Check" Logfile steht ein Abbruch des Updates mit unten genannten Meldungen.

INFO: 14:48:53 Try 3: Checking file size of download...
INFO: 14:48:54 Returned file size:
INFO: 14:48:54 Try 4: Checking file size of download...
INFO: 14:48:55 Returned file size:
INFO: 14:48:55 Try 5: Checking file size of download...
INFO: 14:48:56 Returned file size:
CRITICAL: 14:48:56 Error downloading file.

Ursache und Lösung

Bei GitHub scheint sich etwas geändert zu haben, jedenfalls beantwortet GitHub, von wo die LoxBerry Updates direkt geladen werden, eine Standardanfrage zur Ermittlung der Dateigröße nicht mehr. Wir wissen nicht, ob das alle betrifft, oder viele oder nur manche.

Dadurch können betroffene LoxBerrys nicht auf V1.2.4 oder höher aktualisieren.

Wir haben wir hier ein LoxBerry Update FIX-Plugin bereitgestellt, das einmalig die Installationsroutine behebt:

→ Plugin "LoxBerry Update FIX"

Diesen Download als Plugin installieren. Dies behebt den Fehler beim Update. Nach der Installation des Plugins kann LoxBerry Update normal verwendet, und das Plugin wieder deinstalliert werden.


Wir haben in V1.2.4 diese Dateigrößenüberprüfung vor dem eigentlichen Download ausgebaut und verlassen uns in Zukunft auf den Integritätscheck beim Entpacken. Deswegen funktioniert ab V1.2.4 das LoxBerry Update wieder wie gewohnt.


8 Kommentare

  1. Stefan Mayer sagt:

    Hallo 


    ich kann leider kein Update ausführen habe immer folgende Fehlermeldung:

    ================================================================================
    <LOGSTART>27.10.2018 15:55:09 TASK STARTED
    <LOGSTART>LoxBerry Update Check
    <INFO> Version of loxberrycheck.pl is 1.2.0.3
    <INFO> Executing user of loxberryupdatecheck is root
    <OK> Parameters/settings of this update:
    <INFO> querytype: release

    <INFO> cron:

    <INFO> keepupdatefiles:
    <INFO> dryrun:

    <INFO> output: 1
    <INFO> Current LoxBerry version: v1.2.0.2
    <INFO> Updates limited from : v0.3.0
    <INFO> Updates limited to : v1.99.99
    <INFO> Start checking releases...
    <INFO> Checking for releases from https://api.github.com/repos/mschlenstedt/Loxberry/releases
    <INFO> Requesting release list from GitHub...
    <INFO> Try 1: Getting release list... (27.10.2018 15:55:09)
    <WARNING> API call try 1 has failed. (27.10.2018 15:55:09) HTTP 500 Can't connect to api.github.com:443
    <INFO> Try 2: Getting release list... (27.10.2018 15:55:10)
    <WARNING> API call try 2 has failed. (27.10.2018 15:55:10) HTTP 500 Can't connect to api.github.com:443
    <INFO> Try 3: Getting release list... (27.10.2018 15:55:10)
    <WARNING> API call try 3 has failed. (27.10.2018 15:55:10) HTTP 500 Can't connect to api.github.com:443
    <INFO> Try 4: Getting release list... (27.10.2018 15:55:10)
    <WARNING> API call try 4 has failed. (27.10.2018 15:55:10) HTTP 500 Can't connect to api.github.com:443
    <INFO> Try 5: Getting release list... (27.10.2018 15:55:10)
    <WARNING> API call try 5 has failed. (27.10.2018 15:55:10) HTTP 500 Can't connect to api.github.com:443
    <ERROR> Abrufen der Release-Liste ist fehlgeschlagen: 500 Can't connect to api.github.com:443
    <INFO> JSON: {"error":"Abrufen der Release-Liste ist fehlgeschlagen: 500 Can't connect to api.github.com:443","logfile":"/opt/loxberry/log/system_tmpfs/loxberryupdate/updatecheck.log"}
    <CRITICAL> Abrufen der Release-Liste ist fehlgeschlagen: 500 Can't connect to api.github.com:443
    <CRITICAL> LoxBerry Updatecheck exited or terminated with an error. Errorcode: 1
    <LOGEND>
    <LOGEND>27.10.2018 15:55:10 TASK FINISHED
    ================================================================================
    <LOGSTART>27.10.2018 15:55:29 TASK STARTED
    <LOGSTART>LoxBerry Update Check
    <INFO> Version of loxberrycheck.pl is 1.2.0.3
    <INFO> Executing user of loxberryupdatecheck is root
    <OK> Parameters/settings of this update:
    <INFO> querytype: release

    <INFO> cron:

    <INFO> keepupdatefiles:
    <INFO> dryrun:

    <INFO> output: 1
    <INFO> Current LoxBerry version: v1.2.0.2
    <INFO> Updates limited from : v0.3.0
    <INFO> Updates limited to : v1.99.99
    <INFO> Start checking releases...
    <INFO> Checking for releases from https://api.github.com/repos/mschlenstedt/Loxberry/releases
    <INFO> Requesting release list from GitHub...
    <INFO> Try 1: Getting release list... (27.10.2018 15:55:30)
    <WARNING> API call try 1 has failed. (27.10.2018 15:55:30) HTTP 500 Can't connect to api.github.com:443
    <INFO> Try 2: Getting release list... (27.10.2018 15:55:30)
    <WARNING> API call try 2 has failed. (27.10.2018 15:55:30) HTTP 500 Can't connect to api.github.com:443
    <INFO> Try 3: Getting release list... (27.10.2018 15:55:30)
    <WARNING> API call try 3 has failed. (27.10.2018 15:55:30) HTTP 500 Can't connect to api.github.com:443
    <INFO> Try 4: Getting release list... (27.10.2018 15:55:30)
    <WARNING> API call try 4 has failed. (27.10.2018 15:55:30) HTTP 500 Can't connect to api.github.com:443
    <INFO> Try 5: Getting release list... (27.10.2018 15:55:30)
    <WARNING> API call try 5 has failed. (27.10.2018 15:55:31) HTTP 500 Can't connect to api.github.com:443
    <ERROR> Abrufen der Release-Liste ist fehlgeschlagen: 500 Can't connect to api.github.com:443
    <INFO> JSON: {"error":"Abrufen der Release-Liste ist fehlgeschlagen: 500 Can't connect to api.github.com:443","logfile":"/opt/loxberry/log/system_tmpfs/loxberryupdate/updatecheck.log"}
    <CRITICAL> Abrufen der Release-Liste ist fehlgeschlagen: 500 Can't connect to api.github.com:443
    <CRITICAL> LoxBerry Updatecheck exited or terminated with an error. Errorcode: 1
    <LOGEND>
    <LOGEND>27.10.2018 15:55:31 TASK FINISHED
    ================================================================================
    <LOGSTART>27.10.2018 15:55:36 TASK STARTED
    <LOGSTART>LoxBerry Update Check
    <INFO> Version of loxberrycheck.pl is 1.2.0.3
    <INFO> Executing user of loxberryupdatecheck is root
    <OK> Parameters/settings of this update:
    <INFO> querytype: release

    <INFO> cron:

    <INFO> keepupdatefiles:
    <INFO> dryrun:

    <INFO> output: 1
    <INFO> Current LoxBerry version: v1.2.0.2
    <INFO> Updates limited from : v0.3.0
    <INFO> Updates limited to : v1.99.99
    <INFO> Start checking releases...
    <INFO> Checking for releases from https://api.github.com/repos/mschlenstedt/Loxberry/releases
    <INFO> Requesting release list from GitHub...
    <INFO> Try 1: Getting release list... (27.10.2018 15:55:36)
    <WARNING> API call try 1 has failed. (27.10.2018 15:55:37) HTTP 500 Can't connect to api.github.com:443
    <INFO> Try 2: Getting release list... (27.10.2018 15:55:37)
    <WARNING> API call try 2 has failed. (27.10.2018 15:55:37) HTTP 500 Can't connect to api.github.com:443
    <INFO> Try 3: Getting release list... (27.10.2018 15:55:37)
    <WARNING> API call try 3 has failed. (27.10.2018 15:55:37) HTTP 500 Can't connect to api.github.com:443
    <INFO> Try 4: Getting release list... (27.10.2018 15:55:37)
    <WARNING> API call try 4 has failed. (27.10.2018 15:55:37) HTTP 500 Can't connect to api.github.com:443
    <INFO> Try 5: Getting release list... (27.10.2018 15:55:37)
    <WARNING> API call try 5 has failed. (27.10.2018 15:55:37) HTTP 500 Can't connect to api.github.com:443
    <ERROR> Abrufen der Release-Liste ist fehlgeschlagen: 500 Can't connect to api.github.com:443
    <INFO> JSON: {"logfile":"/opt/loxberry/log/system_tmpfs/loxberryupdate/updatecheck.log","error":"Abrufen der Release-Liste ist fehlgeschlagen: 500 Can't connect to api.github.com:443"}
    <CRITICAL> Abrufen der Release-Liste ist fehlgeschlagen: 500 Can't connect to api.github.com:443
    <CRITICAL> LoxBerry Updatecheck exited or terminated with an error. Errorcode: 1
    <LOGEND>
    <LOGEND>27.10.2018 15:55:37 TASK FINISHED

    1. Hi, hat dein Loxberry zugriff auf das Internet? 

      In der Fehlermeldung steht, dass es nicht möglich war, eine Verbindung zu github aufzubauen.

  2. Stefan Mayer sagt:

    Hallo Jörg 


    vielen dank für die schnelle Antwort


    Der Loxberry wurde laut der Beschreibung eingerichtet. Ich habe auch die Netztwerk text datei eingefügt und er hängt am Netzwerk.


    Gruß Stefan

    1. Hallo Stefan,

      ja, intern kommst du scheinbar drauf. Sonst hättest Du ja auch den Fehler nicht posten können (Zwinkern)

      Kommst du mit deinem PC ins Internet? Dein LB erreicht die Seite von github einfach nicht. 

  3. Stefan Mayer sagt:

    Hallo Jörg 

    ja komm mit meinem PC ins Internet ! Kann man auch das Update direkt laden ?

    1. Hallo Stefan,

      du kannst das Update nicht manuell installieren.

      Dein LoxBerry muss Internet-Zugriff haben, was er offenbar nicht hat. Probier an der LoxBeery-Shell mal ping www.google.at und www.github.com oder sowas, das muss funktionieren, und wenn nicht, stimmt etwas mit deinem Netzwerk nicht.

      lg, Christian

  4. Hallo Ihr,


    nachdem ich das Plugin installiert habe, kommt die Fehlermeldung:

    Error: Abrufen der Release-Liste ist fehlgeschlagen: 500 Can't connect to api.github.com:443

    Könntet ihr mir Hilfe anbieten?


    1. Das ist ein Problem mit deiner Internet-Verbindung des LoxBerry.