Skip to end of metadata
Go to start of metadata

Einleitung

„homebridge“ macht smarte, jedoch nicht Apple zertifizierte Geräte, Apple HomeKit kompatibel.
Mit der folgenden Anleitung kann man seine Loxone Geräte dann mittels Siri bzw. der "Home" App steuern.

Voraussetzung

Docker muss auf einem kompatiblen System installiert sein

  • QNAP: Container Station
  • Synology: Docker
  • RPi, Windows, Linux: Docker

Schritt-für-Schritt-Anleitung (beispielhaft QNAP)

QNAP Weboberfläche

  • In der Filestation einen Ordner anlegen (bspw. Container/homebridge)
  • Container-Station starten neuen Container erstellen (Menüpunkt „Create“)
  • nach homebridge suchen
  • "oznu/homebridge"(latest) container installieren
  • Standard Settings: Namen frei wählen

Advanced Settings:
Environment

Name

Value

HOMEBRIDGE_CONFIG_UI

1

HOMEBRIDGE_CONFIG_UI_PORT

8585 (beliebiger, freier Port am QNAP)

TZ

Vienna (dein Heimatort)

Network
Host auswählen

Shared Folder

Volume from host

Mount Point



/Container/homebridge (der zuvor angelegte Ordner)

/homebridge

Read

Write

  • “Create” klicken

Homebridge im Webbrowser aufrufen

  • http://IP-Adresse-der-QNAP:8585 (der zuvor gewählte UI_PORT)   Nutzername/ Passwort: admin/admin
  • Plugins
    Nach „Loxone“ suchen, das „homebridge-loxone-connect“ Plugin installieren und danach in den Einstellungen die entsprechenden Zugangsdaten des Miniservers eintragen


Das wars auch schon!

Viel Erfolg und vor allem viel Spaß!

Verwandte Artikel

9 Comments

  1. Hallo liebes Forum,

    ich bin neu hier und bin mir nicht sicher ob ich hier richtig bin, ich versuche es dennoch. Ich habe die oben aufgeführte Anleitung verfolgt und versuche auf meinem QNAP die homebridge einzurichten und mit meinem iPhone zu verbinden. Ziel soll es sein, mein Fibaro HC2 darüber zu steuern.

    Leider bekomme ich die homebride nicht 2sauber" gestertet und ich finde keine Lösung. Der log steht folgende Warnunge

    -----------------------------------------------------------------------------------------------------------------

    npm info ok                                                                                                                                                                                      
    *** WARNING *** The program 'node' uses the Apple Bonjour compatibility layer of Avahi.                                                                                                          
    *** WARNING *** Please fix your application to use the native API of Avahi!                                                                                                                      
    *** WARNING *** For more information see <http://0pointer.de/avahi-compat?s=libdns_sd&e=node>                                                                                                    
    *** WARNING *** The program 'node' called 'DNSServiceRegister()' which is not supported (or only supported partially) in the Apple Bonjour compatibility layer of Avahi.                         
    *** WARNING *** Please fix your application to use the native API of Avahi!                                                                                                                      
    *** WARNING *** For more information see <http://0pointer.de/avahi-compat?s=libdns_sd&e=node&f=DNSServiceRegister>                                                                               
    npm info it worked if it ends with ok                                                                                                                                                            
    npm info using npm@5.3.0                                                                                                                                                                         
    npm info using node@v8.4.0                                                                                                                                                                       
    npm info ok                                                                                                                                                                                      
    [2017-9-20 16:37:26] Loaded plugin: homebridge-loxone-ws                                                                                                                                         
    homebridge API version: 2.2                                                                                                                                                                      
    [2017-9-20 16:37:26] Registering platform 'homebridge-loxoneWs.LoxoneWs'                                                                                                                         
    [2017-9-20 16:37:26] ---                                                                                                                                                                         
    [2017-9-20 16:37:26] There was a problem reading your config.json file.                                                                                                                          
    [2017-9-20 16:37:26] Please try pasting your config.json file here to validate it: http://jsonlint.com                                                                                           
    [2017-9-20 16:37:26]                                                                                                                                                                             

    /usr/local/lib/node_modules/homebridge/lib/server.js:197

     

    -------------------------------------------------------------------------------------------------

     

    Vielen Dank für die Hilfe,

    MfG Daniel

    1. Hi Daniel,

      ich kann dir leider adhoc auch nicht helfen, würde dir aber raten einen Thread im forum zu erstellen. Dort ist eigentlich der richtige Platz dafür und die Leserschaft auch definitiv größer.

      LG Herbert

  2. Hallo,

    ich konnte die HomeBridge erfolgreich starten. Sie wurde auch in Home erkannt, allerdings hat sie nur einen Bruchteil meiner Geräte übernommen. Eigentlich nur die Lichter und Verbraucher.

     

    mfg

    P.S.

    Wichtig ist das man in der config.json die Anmerkungen entfernt bevor man die Datei speichert. Sonst läuft der Prozess auf Fehler.

  3. Hi Carsten,

    ich hatte dasselbe Problem. Hab dann mehrere Instanzen installiert, am RPi probiert. Immer dasselbe Problem.

    Es stellte sich heraus, dass das ein Verhalten der Homebridge ist.Die erkennt nämlich nur Geräte die anders heißen. Bedeutet, dass der Raumname nicht abgefragt wird sondern nur die Bezeichnung des Bausteins.

    In der Loxone Config: (bspw. Licht)

    Raum Wohnzimmer / Lichtbaustein / Bezeichnung: Decke

    Raum Esszimmer / Lichtbaustein / Bezeichnung: Decke

    nur eins wird erkannt.

    Raum Wohnzimmer / Lichtbaustein / Bezeichnung: Wohnzimmer Decke

    Raum Esszimmer / Lichtbaustein / Bezeichnung: Esszimmer Decke

    beide werden erkannt.

     

    Hoffe ich konnte helfen.

    MfG

     

  4. was soll denn hier beim .json script als username eingetragen werden? die NAS Mac adresse?? oder woher kommt der wert.


    Aktuell hab ich das problem, dass sich der container im loop dauernd restartet. denke, dass liegt wohl am login welches im script mitgegeben wird. Bzw. gibts hier noch mehr infos dazu. DANKE schonmal


    Grüße

    Norbert

    1. Den usernamen (MAC) bei "Homebridge" habe ich unberührt gelassen. Also so steht das Script auch auf github. Ich nehme jedoch an, dass er frei wählbar ist.

      Jedenfalls sollte es eine einmalige MAC sein. Die vom NAS wird nicht funktionieren.

      Wenn der Container im Loop rebootet ist mit ziemlicher Sicherheit am config.json was faul.

      Ich habe nur die Zeilen angepasst die einen Kommentar mit // haben.  Lösch die Kommentare im fertigen config.json weg.  Ich vermute hier liegt das Problem.



      1. Hy, danke für die info... hab auf die "Kommentare" vergessen. das war des rätsels lösung.


        ciao

        1. Gern! Freut mich, dass es funktioniert hat.

  5. Hallo zusammen, hatte vor mehreren Monaten bereits erfolgreich das Plugin via Docker auf meiner DS918 installiert und hatte bis zuletzt keine Probleme.

    Leider ging mir eine HDD der NAS kaputt, genau jenes, welches nicht gespiegelt war und die Docker sowie die Container beinhaltete..


    Hab nun auf neuer HDD (jetzt aber gespiegelt) docker mit dem container neu installiert, aber bekomm es nicht mehr zum laufen, kommt immer diese Fehlermeldung "usr/local/lib/node_modules/homebridge/lib/api.js:122 throw new Error("The requested platform '" + name + "' was not registered by any plugin.");"



    Jemand infos zu . einer Problemlösung!? Wäre sehr dankbar


    Ciao

    Norbert