Zum Ende der Metadaten springen
Zum Anfang der Metadaten

Problem

Wollte bei meinem Loxberry Netzwerkfreigaben hinzufügen, was jedoch nicht klappt. Kann mir dies bezüglich jemand weiterhelfen ?

Lösung

 

21 Kommentare

  1. Mach mal 

    ls /opt/loxberry/system/storage/smb/192.168.178.12

    und

    ls /opt/loxberry/system/storage/smb/192.168.178.12/music


    Aus meiner Sicht hat dein User einfach keine Rechte - die Shares selbst werden nämlich gesehen.

  2. Hallo Herr Fenzl

    Wenn ich über den Filemanager des Loxberry den Ordner abfrage, steht immer dort: Folder is empty.

    Der Benutzer ist als admin angelegt und sollte alle Rechte haben.

    1. Hallo Christian, kannst du bitte lt. Eine SSH-Verbindung mit putty aufbauen / Shell-Zugriff anmelden und die genannten Befehle ausführen.

      Für Debugging-Zwecke brauche ich das, weil genau das der Code macht, um zu prüfen, ob die Verzeichnisse erreichbar sind.

      Danke, Christian

  3. Hallo

    Anbei der Code:

    login as: loxberry
    loxberry@192.168.178.50's password:
    Linux loxberry 4.14.30-v7+ #1102 SMP Mon Mar 26 16:45:49 BST 2018 armv7l
    The programs included with the Debian GNU/Linux system are free software;
    the exact distribution terms for each program are described in the
    individual files in /usr/share/doc/*/copyright.
    Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
    permitted by applicable law.
    loxberry@loxberry:~ $ ls /opt/loxberry/system/storage/smb/192.168.178.12
    homes  music  photo  Public  surveillance  video  web
    loxberry@loxberry:~ $ ls /opt/loxberry/system/storage/smb/192.168.178.12/music
    ls: cannot open directory '/opt/loxberry/system/storage/smb/192.168.178.12/music       ': No such file or directory
    loxberry@loxberry:~ $

  4. Habe genau das selbe Problem.

    Server wird mit "OK" hinzugefügt, aber es sieht dann genauso aus wie bei Christian Gruber

  5. Hallo Mayrhauser Harald

    Ich hatte schon das Gefühl das ich der einzige mit dem Problem bin. Jetzt die Bestätigung, nicht allein zu sein. 

    Lg Christian 

  6. Das Problem habe ich schon länger, habs aber bis dato nicht gebraucht. Ich schätze seit LB 1.x.x.x

    Weiß es leider nicht mehr genau. 

    1. Die Funktion ist erst nach LB1.0 gekommen. Vorher hattest du das Problem also bestimmt nicht (Zwinkern)

  7. @Mayrhauser Harald

    Werde es morgen auf einer anderen SD Karte versuchen ein anderes System aufzuspielen um zu schauen ob da das Problem weiter besteht  Lg


    1. Neuinstallation brauchst du nicht machen, bringt nichts.

      Es ist vermutlich ein Auth-Problem beim Mounten. Ihr könnt nichts machen wegen eures NAS (oder was auf der anderen Seite ist), und wir können nichts machen, weil wir das NAS nicht zum Testen haben.

      Bei Windows funktioniert es, und bei manchen NAS, mehr können wir nicht probieren.

      Ihr könnt euch helfen, indem ihr selbst in der fstab mountet. 

      Schreibt mal im Forum einen Beitrag und nennt dort das Gerät, wo ihr hin verbindet. Fehler ist, die Shares sind sichtbar, aber ls <Share> bringt „Not found“.

      Vielleicht findet sich jemand, der die Lösung kennt, und uns beim Fixen helfen kann.


      lg, Christian

  8. @ Christian Fenzl

    Danke für die Info  Kann die Zeit dann anderwertig verbringen. 

    Lg Christian 

  9. Danke!!

    Könnte es am SMB Protokoll v1 Problem liegen?

    Habe ein DLINK DNS-323 NAS. 


    Grüße


  10. Habe eine Synology DS216+II 

  11. Mayrhauser Harald

    Christian Fenzl

    Hallo, mit diesen Einstellungen werden jetzt die Netzwerkfreigaben angezeigt.

    lg

    Christian

    1. philox sagt:

      Kann diese Lösung bestätigen. Habe genau das gleiche Problem gehabt mit einer Synology DS216play und mit der Erhöhung auf SMB3 sehe ich nun die Ordner!


      Danke @Christian Gruber !

  12. Super! Welche der Settings war schlussendlich ausschlaggebend?

    1. Das Maximale SMB-Protokoll was auf SMB 2 eingestellt. Bei SMB 3 werden alle Freigaben sichtbar.

      glg Christian

  13. Also doch ein SMB Protokoll Fehler. Danke!!

    Hoffe ich dann da bei meiner alten NAS was einstellen. 

  14. Jetzt fehlt oben im Artikel nur noch die Lösung (Lächeln)

  15. Ich hab es gerade auch ausprobiert.

    NAS: Der interne Speicher meiner Fritz.Box 7490 (Hab zum testen nichts anderes da.)

    Bekomme die Freigaben nicht angezeigt. Zugriff per SMB ist erlaubt und der Benutzer hat die entsprechenden Rechte.

  16. Martin Reini sagt:

    Hi all, kenn mich leider wenig aus, aber für mich hab ich eine (temporäre Lösung).

    wer wie ich eine alte NAS hat (WD Mybook), wo man SMBv3 nicht einstellen kann, dem könnte folgendes helfen (wobei der Sicherheit halber es wohl besser wär, das Teil wegzuwerfen und was kaufen, wo es Firmware mit SMBv3 gibt. 

    mount -t cifs -o vers=2.0, .... usw.,usw

    Lösung hab ich von hier: https://wiki.ubuntuusers.de/Samba_Client_cifs/

    lg