Zum Ende der Metadaten springen
Zum Anfang der Metadaten

Allgemein

Installation

pi@raspberrypi $ sudo su

root@raspberrypi $ apt-get update
root@raspberrypi $ apt-get install git python3 python3-pip

root@raspberrypi $ python3 --version
Python 3.4.2

root@raspberrypi $ git --version
git version 2.1.4


root@raspberrypi $ cd /opt
root@raspberrypi $ git clone https://github.com/escalate/loxone-ha-bridge-importer.git
root@raspberrypi $ cd loxone-ha-bridge-importer/


root@raspberrypi $ pip3 install -r requirements.txt

Verwendung

Aufruf der Hilfe

root@raspberrypi $ python3 importer.py --help

Beispielhafter Aufruf

root@raspberrypi $ python3 importer.py \
    --loxone-miniserver 192.168.1.2:7777 \
    --loxone-username alexa \
    --loxone-password AmAz0n \
    --verbose
  • Keine Stichwörter

11 Kommentare

  1. Hallo!

    Was genau wird alles importiert ?

    Grüße 

    1. Hallo Harald,


      es werden alle Controls importiert, die ich bereits mit sinnvollen Aktionen (on, dim, off) belegen konnte.

      Eine Liste der unterstützten Controls findest du im README https://github.com/escalate/loxone-ha-bridge-importer

  2. Hallo !


    Man sollte noch dazu sagen, dass man sich als Root-Benutzer anmelden muss ! (Zwinkern)

    1. Hallo Harald,


      ich habe die Anleitung etwas umgeschrieben sodass dein Punkt hoffentlich abgedeckt wird.

  3. Hallo,

    Ich bekomme immer nach Eingabe --verbose folgenden Fehler.

    Traceback (most recent call last):

      File "importer.py", line 8, in <module>

        import requests

    ImportError: No module named 'requests'


    Kann mir bitte jemand helfen?

    1. Hallo Thomas,

      der Fehler deutet darauf hin, dass du die abhängigen Bibliotheken nicht installiert hast.

      Das Kommando:  pip3 install -r requirements.txt erledigt diesen Teil .

  4. Ben sagt:

    Ist es möglich, dass keine Passwörter mit Sonderzeichen anerkannt werden - z.B. mit vorangestelltem Ausrufezeichen?!

    Ich erhalte als Feedback event not found

  5. Christian sagt:

    Hi,


    bei mir läuft der Importer leider auch nicht...

    requests.exceptions.ConnectTimeout: HTTPConnectionPool(host='192.168.0.x', port=7777): Max retries exceeded with url: /data/LoxAPP3.json (Caused by ConnectTimeoutError(<urllib3.connection.HTTPConnection object at 0x761b7c70>, 'Connection to 192.168.0.x timed out. (connect timeout=5)'))
    root@loxberry:/opt/loxone-ha-bridge-importer#

    jmd eine Ahnung woran es liegen könnte?

    1. Tim sagt:

      Bei mir passiert genau das selbe.

  6. Christian sagt:

    Ich habs jetzt einfach manuell gemacht... also ohne den Importer... funktioniert super!

    1. Tim sagt:

      Stimmt funktioniert auch gut, ist aber ungleich aufwändiger.