Skip to end of metadata
Go to start of metadata

Usage of the logging module

LoxBerry 0.3.x

Diese Information ist gültig für LoxBerry V1.0 und höher. Ältere LoxBerry Versionen haben dieses Feature noch nicht integriert. Wenn Du es verwendest, solltest Du in der Plugin-Konfiguration die Mindestversionsnummer des LoxBerry auf 1.0 setzen

 

Falls Dein Plugin auf verschiedenen Hardware-Architekturen unterschiedliche Aktionen bei der Installation benötigt (z. B. um unterschiedliche Binaries zu installieren oder die Installation ganz abzubrechen), kannst Du in den Installationsskripten (z. B. postinstall.sh) folgende Abfrage verwenden:

 

Hardware Architektur abfragen
if [ -e $LBSCONFIG/is_raspberry.cfg ]; then
echo The hardware architecture is RaspBerry
fi
if [ -e $LBSCONFIG/is_x86.cfg ]; then
echo The hardware architecture is x86
fi
if [ -e $LBSCONFIG/is_x64.cfg ]; then
echo The hardware architecture is x64
fi
  • No labels