Zum Ende der Metadaten springen
Zum Anfang der Metadaten

Kommunikation mit Wechselrichter

Netzwerkfähige Wechselrichter der Firma Kostal werden direkt unterstützt

Mit dem Energiemonitor Baustein kann der Wechselrichter in Loxone eingebunden werden.

  • Keine Stichwörter

13 Kommentare

  1. Eine Info zum Verbinden des WR mit Loxone: Die IP Adresse muss ohne "HTTP://" eingegeben werden. Steht in der Online Doku leider nicht drin und bis ich es in der Config gesehen hatte, sind paar Stunden Suchen drauf gegangen.

  2. Hi, müsste ein Kostal WR mit PIKO 5.5 auch funktionieren? (KOSTAL Connection on Port 81 FAIL) Loxone Config 9.0.9.26

    1. Ja, das funktioniert auch, ich habe einen 5.5er. Überprüf nochmal deine Verbindung des WR (Port 81 ist der UDP Port über den die Nachrichten verschickt werden).

  3. Ich habe auch einen Kostal WR (mit Speicher) und die gleiche FAIL Meldung wie Gerhard. Da muss man wohl mal bei Loxone nachfragen.

    Im Moment behelfe ich mir mit Objekteingängen!

  4. Hallo Sascha,

    Welchen Kostal Hybrid WR hast Du - den Piko BA mit HV Batterie?

    Bist Du zufrieden damit?

    Gibt es Deiner Meinung nach eine Mindestgrenze an Leistung die abgerufen werden muss, damit der WR "gegensteuert" - oder geht das auch im Bereich von 100-300w "Grundlast"?

    Anbindung an Loxone klappt mittlerweile?


    Bitte um kurze RÜ - danke.

  5. Hallo Michael,

    tut mir sehr leid, dass ich so spät antworte.

    Also ich habe einen PIKO 6.0 BA, mehr kann ich Dir dazu aber leider (noch) nicht sagen.
    Kostal wurde von unserem Hausbauer mit angeboten. Da es leicht in Loxone integrierbar war und ich allgemein nicht viel Negatives hörte, war die Sache für mich erledigt.

    Wir sind erst im November eingezogen, daher kann ich noch nicht sagen, wie zufrieden ich bin.
    Fakt ist, dass der Kostal WR (mit Speicher) wohl nicht mehr "out-of-the-box" in Loxone integrierbar ist und laut meines Hausbauers, dies wohl auch nicht so schnell passieren wird, da sich Loxone vor allem auf Fronius konzentriert.

    Man kann die Daten allerdings relativ einfach über den Webserver des WR abfragen, dort werden sie als JSON-Array geliefert.
    Schwieriger wird es dann, rauszufinden, werlcher Wert wofür steht.
    Ich kann Dir gerne mal meine Loxone-Konfiguration schicken.

    Viele Grüße
    Sascha

  6. Christian sagt:

    Hallo Sascha,


    hast du die Abfrage über JSON schon umgesetzt?

    Könntest du mir bitte mal deine Konfiguration für die Webserver-Abfrage zukommen lassen?


    Danke schon im Voraus. 


    Gruß

    Christian

  7. Hallo Christian,

    ja, ich habe die JSON Abfrage umgesetzt.
    Ich versuche mich gerade an einem kleinen Wiki-Artikel. Mit etwas Glück (und vor allem Zeit) bekomme ich ihn am Wochenende live, dann kannst Du´s mal ausprobieren.

    Viele Grüße
    Sascha

  8. Hallo Sascha,

    Danke für die Antwort - werde den Kostal Piko BA weiter in meine Überlegungen miteinbeziehen. 

    LG


    Michael

  9. Rainer Voß sagt:

    Hallo zusammen,

    super Beschreibung für Kostal WR.

    Habe nur noch ein Problem, wenn ich das so mache wie in der Beschreibung, beim Ladezyklus der Batterie mit der richtigen Skalierung geht alles, aber bei der Entladung werden mir nur Watt Werte übergeben.


    „Im virtuellen Eingangsbefehl zum Laden/Entladen der Batterie geben wir bei den Eigenschaften im "Anzeigewert 1", der Korrektur -1 an.``


    Oder kann mir eine Musterdatei zukommen lassen?

    Habe eine Kostal PIKA 6.0 BA

     

    Wer kann mir da weiterhelfen?

    Danke im Voraus

  10. Hallo Rainer,

    Dein Kommentar gehört wohl eigentlich auf die Seite "Auslesen der Werte über HTTP".
    Ich verstehe aber leider Dein Problem nicht. Deine Screenshots scheinen jedenfalls völlig in Ordnung zu sein oder übersehe ich etwas?
    Du speist den Energiemonitor am Eingang Ps mit KW, positive Werte für Entladen, negative für Laden.
    Wann der Energiemonitor in der Visualisierung Watt oder KW anzeigt, kann man nicht beeinflussen, das ist Loxone Magic.
    Ich vermute mal, dass alles unter 1,0 kW als Watt angezeigt wird.

    Viele Grüße
    Sascha 

  11. Rainer Voß sagt:

    Hallo Sascha,

    ja das ist richtig es wird nur in Watt übergeben, habe mich falsch ausgedrückt.


    Anbei ein Screenshot. Wenn die Batterie entladen wird sind die Werte aber nicht richtig,

    angezeigte Entladung ist  9,2W müssten aber 921W sein.


     


    Beim Entladen der Batterie wird im virtuellen Eingangsbefehl zum Laden/Entladen der Batterie, nach der Korrektureingabe von ``-1`` der Wert ``0`` übergeben (müsste aber ``1`` sein um einen positiven Wert zu erhalten oder?


    Gruß

    Rainer

  12. Seh ich das in Deinem Screenshot richtig, dass nach dem "Multiplizieren" aus 921 ein 9,21 wird?
    Hast Du beim Eingangswert 2 eventuell eine 100 stehen?

    Die Korrektur des Eingangsbefehls "Laden/Entladen" sieht wie folgt aus:

    Eingangswert 10
    Zeilwert 1-1
    Eingangswert 21
    Zielwert 21