Versionen im Vergleich

Schlüssel

  • Diese Zeile wurde hinzugefügt.
  • Diese Zeile wurde entfernt.
  • Formatierung wurde geändert.

...

  • Warum erscheint bei mir nicht das Verzeichnis "sonos_tts" auf dem LoxBerry?
  • Bei der Installation des Plugins wird normalerweise ein neuer Eintrag in der Datei smb.conf erstellt um das tts Verzeichnis für Sonos zugänglich zu machen. Falls nach einer Installation mit anschließendem Neustart das Verzeichnis nicht vorhanden sein sollte entweder Neuinstallieren oder die Datei smb.conf manuell ändern.
    Dazu bitte die Datei system/samba/smb.conf öffnen und folgenden Eintrag/Block am Ende der Datei einfügen:
    [sonos_tts]
    comment = Loxberry Files
    path = /opt/loxberry/data/plugins/sonos4lox/tts
    guest ok = yes
    read only = no
    directory mask = 0700
    create mask = 0700
    anschließend speichern und Loxberry neustarten bzw. Samba neu starten
  • Warum bekomme ich beim Scan Zonen keine Player angezeigt?
  • Ist evtl. in der Sonos App der UPnP Dienst deaktiviert. Bitte Sonos Einstellungen überprüfen
  • Ich verwende eine Sonos Bridge in meinem Netzwerk. Am besten entfernen und erneut scannen.
  • Was mache ich wenn ich eine Zone nicht mehr benötige?
  • Vor der nicht mehr benötigten Zone den Papierkorb anticken und speichern
  • Was mache ich wenn ich eine Zone in der Sonos App umbennene? 
  • Vor der umbenannten Zone den Papierkorb anticken und speichern. Anschließend den Scan neu ausführen, Daten ergänzen und speichern. Ggf. den Raum in den Ausgangsverbindern im MS anpassen.
  • Was mache ich wenn ich eine neue Zone hinzufügen möchte?
  • Den Scan erneut aufrufen, Daten ergänzen und speichern
  • Warum bekomme ich bei T2S eine Fehlermeldung bezüglich curl_init?
  • Du hast das LoxBerry Image auf einer VM installiert. Aus derzeit unerfindlichen Gründen werden 3 Pakete bei der Grundinstallation vom LoxBerry nicht installiert. Bitte installiere mit dem root User manuell folgende Pakete: apt-get install curl libcurl3 php5-curl
  • Warum bekomme ich einen Fehler bei einer Gruppendurchsage?
  • Eine Zone darf innerhalb der Syntax nur einmal verwendet werden und nicht über member= noch einmal hinzugefügt werden.
  • Bsp. falsch: http://<DEINE IP>/plugins/sonos4lox/index.php?zone=kueche&action=sendgroupmessage&member=kueche,buero&text=dies ist ein test&groupvolume=15
  • Bsp. richtig: http://<DEINE IP>/plugins/sonos4lox/index.php?zone=kueche&action=sendgroupmessage&member=buero&text=dies ist ein test&groupvolume=15
  • Warum habe ich in der Fehlermeldung "REPLACEBYSUBFOLDER" stehen?
  • Der Installation des Plugins wurde nicht korrekt bis zum Ende ausgeführt, so dass in der Datei sonos.cfg der Eintrag REPLACEBYSUBFOLDER nicht durch sonos4lox ersetzt wurde.
  • Datei sonos.cfg mit einem Editor öffnen und REPLACEBYSUBFOLDER durch sonos4lox ersetzen.
  • Warum bekomme ich keine Daten per UDP in den Miniserver?
  • Der Datentransfer in der Konfiguration ist ausgeschaltet.
  • Das Portforwarding am Router nicht durchgeführt. (siehe "Miniserveranbindung" → "Portforwarding") 
  • Senderadresse im virtuellen UDP-Eingang leer lassen
  • Warum höre ich keinen playgong/jingle vor meiner T2S?
  • Das Jingle MP3 File muss mit Hilfe von WinSCP oder ähnlichen Tool in folgendes Verzeichnis kopiert werden: /loxberry/data/plugins/sonos4lox/tts/mp3
  • Warum wird keine messageid abgespielt?
  • Die numerischen MP3 Files müssen mit Hilfe von WinSCP oder ähnlichen Tool in folgendes Verzeichnis kopiert werden: /loxberry/data/plugins/sonos4lox/tts/mp3
  • Das Verzeichnis für die Files muss kleingeschrieben sein korrekt: tts/mp3 statt tts/MP3. 
  • Die MP3 Files haben evtl. nicht die erforderliche Berechtigung. Bitte per WinSCP oder ähnlichem Tool die Rechte für das Verzeichnis UND die Dateien auf 0644 setzen → kommt nicht mehr vor da Script das korrigiert
  • Warum wird keine MP3 (T2S oder messageid) abgespielt?
  • Du hast in deinem Router die IPv6 Unterstützung markiert.
  • Dein API-/secret key ist evtl. nicht gültig oder korrupt
  • Warum ist meine Zeile bei den Radio Favoriten leer obwohl ich sie vorher gespeichert habe?
  • Die Verwendung von Sonderzeichen im Feld "Sender Name", hier ganz speziell ein Apostroph, bereiten Probleme. Der Sender wird aber korrekt in die sonos.cfg geschreiben.
  • Warum bekomme ich nur 1x eine T2S und danach muss ich die Zone vom Netz nehmen? Z. B. Fehler "/PHPSonos.php on line 2478" (wird sich mit Release 2.0 erledigen)  → erledigt
  • Derzeit ist mir die Ursache nicht bekannt, ich kann es auch nicht reproduzieren. Ein Workaround ist die aktuelle Playliste aus der Queue löschen, die Zone ca. 2 Minuten vom Strom zu nehmen und dann sollte es funktionieren.
  • Bei Nutzung von Radio oder leerer Queue sollte es einwandfrei funktionieren. Es kann auch sein das evtl. mind. 1 Titel der Playliste (z.B. Streaming Liste) nicht mehr erreichbar ist und von daher gibt es den Fehler beim Speichern der Playliste.
  • Warum wird eine T2S zweimal abgespielt obwohl im virtuellen Ausgangsbefehl nur ein Eintrag bei "Befehl bei EIN" vorhanden ist?
  • Im virtuellen Ausgangsbefehl ist der Haken bei "Als Digitalausgang verwenden" nicht entfernt. Das muss bei Ansage eines Textes mit dem Parameter <v> (Übernahme eines Wertes aus Loxone) durchgeführt werden.
  • Im virtuellen Ausgang ist der Haken bei "Verbindung nach Senden schließen" nicht gesetzt
  • Die Ansage erfolgt basierend auf einer Textgenerierung aus einem Stausbaustein heraus. Hierzu weiter oben im Wiki unter Einzel-/Gruppendurchsagen aus einem Statusbaustein heraus nachschauen.

...